Lightroom Soft Proofing Plugin

Create soft proof images for any profile.
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Lightroom Soft Proofing - Manual

Introduction
This plugin will create soft-proof images for any of your photos, in an interactive dialog inside
Lightroom 2 or better. You can save the proofed images back into your catalog.

CONTACT AND SUPPORT
You can get support or ask questions in the support forums:
http://www.lightroom-plugins.com/contact.php

REQUIREMENTS
– Lightroom 2 or better
– Windows or MacOS X (Intel)

LEGAL STUFF
This plug-in is not specifically endorsed by Adobe Inc®.
The open-source LittleCMS package is used by this plugin. http://www.littlecms.com . The license
details for LittleCMS are:
The MIT License
Copyright (c) 2010 Marti Maria
Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:
The above copyright notice and this permission notice shall be included in
all copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
THE SOFTWARE.
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What's Included

NEW COMMANDS
One new command has been added to the “File ” menu in Lightroom:
1. Create Soft-proof
This opens the soft-proofing dialog,
allowing you to apply different profiles to
the selected photo.

NEW SMART COLLECTIONS
There are no new Smart Collections included with this plug-in.
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Installation
This plug-in adds a new field to your Lightroom database. This is used to store the name of the
profile that was applied, if you decide to store copies of the soft-proofed photos.
Before you install this, you should make sure you have a backup of your Lightroom catalog. If you
do not already have automatic backups enabled, you can perform a single backup by going to
“Edit→Catalog Settings... ” and changing the “Back up catalog” list to “Next time Lightroom starts
only”, and restarting Lightroom.

WINDOWS
Automatic Installation
The easiest way to install on Windows is to use the MSI installer. Simply double-click and run
through the prompts that appear.

Manual Installation
If you prefer to install manually, download the ZIP file instead of the MSI. When it has downloaded,
unzip it and copy the folder called “SoftProof.lrplugin” into Lightroom's “Modules” folder.
This can be found at:
Windows XP: %APPDATA%\Adobe\Lightroom\Modules\
Vista/Windows 7: %APPDATA%\Roaming\Adobe\Lightroom\Modules\

MAC
Download the ZIP and extract it to your desktop. You should see a folder called “SoftProofPlugin”,
containing the plug-in and this manual. Copy the plug-in to Lightroom's “Modules” folder, which is:
MacOS: /Library/Application Support/Adobe/Lightroom/Modules/

To check that the plug-in has been loaded,
go to “File→Plug-in Manager... ” and check
that a plug-in called “SoftProof ” is shown as
“Installed and running”.
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SETTING UP LIGHTROOM
Enter Your Licence Key
If you have bought the plug-in, you should receive a licence key in an email. Without this, the plugin will work in trial mode. In trial mode, the proofed images are very small and some of the profile
names will be hidden. To enter the licence key, simply copy and paste it and your e-mail address
from the email to the box in the Plugin Manager when the SoftProof plugin is selected.
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Using the Plugin
To show the soft-proof window, use the new menu item that is added to the File menu. On
Windows, you can make this faster using the keyboard shortcut Alt+F+S+S . Either way, this will
open the proofing window.

On the left, your original photo is shown. The right-hand photo is the soft-proofed copy. The
controls are split into two groups; the interactive controls at the right, and a collection of preset
controls at the top.

5

http://www.lightroom-plugins.com

Lightroom Soft Proofing - Manual

MAIN CONTROLS
The main controls are at the right of the window:
•

Filter Profiles
ICC profiles are given one of a set of intentions.
Usually, you will want to use profiles which have an
'Output' intention, but you may want to show all
available profiles including those for e.g. scanners. To
show all profiles, un-tick this box. The list of available
profiles in the drop-down list will change.

•

Printer
This is a simple list of all the output profiles available
on your computer. In trial mode, some of these names
are deliberately incorrect. To apply a different profile to the test image on the right, just
choose it from this list.

•

Intent
Two rendering intents are allowed - “Perceptual” and “Relative”. These are the same ones
supported by Lightroom's Print module. Choose which intent you want to use for the softproof; it will update automatically.

•

Gamut Warning
Tick this box to have all out-of-gamut colours highlighted in the proofed image. The colour
used for the highlight can be chosen using the colour-well control to the right of the tickbox.

•

Black-point Compensation
This mirrors the same control in Photoshop.

•

Simulate Paper White
This mirrors the same control in Photoshop.

The final control is beneath the soft-proof image, called “Save and Stack”. This will take the
currently-selected profile and apply it to a full-size copy of the selected photo. It will then save the
resulting image alongside the original, add it to Lightroom's catalog and stack it with the original.
You can use this feature to inspect the proofed images in more detail, using Lightroom's
“Compare” tools.
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PRESET CONTROLS
To make it quicker to switch between your most commonly-used profiles, you can assign four
presets using the buttons on the right-hand side of the window near the top. Use the “Set” button
above each preset option to assign the currently-selected profile to that button. Selecting the
preset button will apply that profile.

It will also store a temporary copy of the resulting soft-proof image on disk, allowing you switch
very quickly between different profiles to see the differences. You can also use the keyboard
shortcuts shown on the buttons in Windows (Alt + 0, 1, 2, 3 or 4).

7

http://www.lightroom-plugins.com

Lightroom Soft Proofing - Manual

What's Soft-Proofing?
Pretty much everyone will have printed a photo at some point and been disappointed with the
results. The colours didn't match, or it was too dark, or in some other way was very different from
the photo you saw on screen. The reason for this is that each output device, including your
monitor, will be different from every other output device and different again from an imaginary
ideal set of colours. Using ICC profiles helps to correct for these differences.

WHAT'S A PROFILE?
In short, an ICC profile is a set of mathematical functions which take a colour and apply a set of
corrections to it, to come up with a different colour. This new colour will be “incorrect” - it is
different from the intended one – but, when it is sent to the output device, the inaccuracies in the
device undo the corrections giving you the original colour back again.
Some printer manufacturers provide ICC profiles with their printers which will give you a fairly
good starting point. They will have measured the printer's response at the factory and then
tailored the printer driver and ICC profile to get a good result. There are several problems here,
though.
First, they will have sampled a small number of printers and then assumed that all of the others
will respond in exactly the same way. They certainly should all be close, but won't be exactly the
same. More importantly, each type of ink and paper will have a different look, meaning that each
will need a different set of colour corrections to get the most accurate result. Most printer drivers
will offer the choice of several paper types (photo, matte, plain etc.) which also help – these adjust
the amounts of ink that get used - but they will not be able to cope with the huge choice of papers
available today.
The answer is use a measured profile, created for your specific printer, ink and paper choices. You
will end up with different profiles for each combination, and potentially even different profiles for
different viewing conditions; a print will look different in sunlight when compared to fluorescent
lighting, for example.
These measurements can be taken with devices like the DataColor Spyder, ColorMunki and others.
They're not cheap, but in the long run will save you money in lost ink and paper used in countless
“wrong” prints, and the time it takes to make them.
Datacolor: http://www.datacolor.eu/en/
ColorMunki: http://www.colormunki.com/
X-Rite : http://www.xrite.com/
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SO WHY SOFT-PROOF?
It's highly unlikely that any output device, even a monitor, will be able to show the full range of
colours that are used in a photo. In particular, very strong or very dark colours tend to cause
problems. When a device is asked to show a colour that it can't cope with, it must somehow
convert it into one it can cope with. This results in a flatter-looking print and, depending on how it
handles the conversion, potentially one with lots of way-off colours.
By using a measured profile, you help the device driver come up with a much closer match for
these unusable (or “out-of-gamut”) colours. Using the information in the profile, it knows exactly
what colours the device is capable of. However, each test print still takes time, ink and paper to
produce.
A soft-proof simulates this process by applying the printer profile to the image, and then
converting the result back for display on your monitor using a slightly different process. This gives a
close indication of how the print would look, without having to actually make the print. You can
then choose whether the result is close enough to print.
If you are not happy with the soft-proofed result, you could then try to adjust the photo so that it
still looks pleasing but is “easier” for the printer to reproduce; that is, more of the photo's colours
lie within the capabilities of the printer and don't need to be converted and compressed. For
example, if your printer doesn't handle intense greens well, making them appear too blue, you can
use Lightroom's normal image editing tools on a virtual copy of the photo to reduce the intensity
of the greens a little. The greens wouldn't be as intense as you might like, but at least they would
be green!
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Known Problems

THE SHORTCUT KEYS DON'T WORK
On Windows the plugin can be started using the shortcut key Alt+F+S+S (Hold down Alt, then press
F, S and S again). Unfortunately, there is no facility for doing this on the Mac.

CHANGE LOG
V1.0.2333
•

MAC: Now works when the plugin path has a space in it

•

FIX: Now deals with incorrect ICC files better

•

FIX: Incorrect proofs could be created in some circumstances

•

NEW: Added Black Point Compensation button

•

FIX: List of profiles uses the description instead of the filename

•

FIX: Profiles in sub-folders weren't being listed

•

NEW: Added "Simulate Paper White"

•

NEW: Can choose to view only the proof image
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